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ÁU.S.E.R. equates to  UDTFs, SQL, Excel, RPG; all the tools that are present in 

your workplace environment. 

 

Á  Using what we already are familiar with on our IBM i and PC; SQL, RPG, DB2, 

RAD and more will allow us to get comfortable with XML so that you can say 

you Grok XML (To grok is to share the same reality or line of thinking with 

another physical or conceptual entity, intermingling of intelligence that 
necessarily affects both the observer and the observed) . 
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ÁXML has become a standard for cross-platform 
communications 
 

ÁXML has or will impact your business if you continue to be 
in business 
 

ÁXML has gained acceptance as a preferred data exchange 
technology in spite of the limitations because of the 
flexibility and human readable formatting 
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What you need to get started: 

 

ÁXML Editing tool(s) 
ÁWDSC, Rational Application Developer (RAD)  (IBM) 

ÁXMLSpy (Altova) 

ÁStylus Studio (Progress Software Corporation) 

ÁMicrosoft Office 2003 or higher 

 

ÁXML Reference(s) 
ÁWDSC Step by Step (MC Press) 

ÁXML for eServer i5 and iSeries (MC Press) 

ÁQshell for iSeries (MC Press) 

ÁXSLT 2nd Edition (WROX) 

ÁW3Schools Online Web Tutorials (www.w3schools.org) 
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 What is XML? 

ïXML is short for Extensible Markup Language 

 

Pros of XML? 

ïXML is flexible 

ïXML is self documenting  

ïXML can replace or extend legacy systems 

 

Cons of XML? 

ïXML is verbose 

ïXML can significantly increases the size of your data 

ïXML works best with hierarchal data in a relational data 
base 
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There are three main components of XML 

 

ÁXML Document 

ÁDocument containing data 

 

ÁXML Document Type Definition (DTD) 

ÁDocument that defines the document structure of the XML 
Document 

 

ÁXML Schema Definition (XSD) 

ÁDocument that defines the document structure of the XML 
Document in an XML-based alternative to DTD 
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Structure of XML documents 

 

ÁAn XML document has a tree-like structure that is hierarchical  

ÁThe document must contain one and only one root element 

ÁAn element is the parent of all the elements it contains  

ÁThe elements that are inside a parent element are called its 
children 

ÁSimilarly, the elements that have the same parent element 
are called siblings 
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Structure of DTD documents 

 

ÁContains the list of tags which are allowed within the XML 
document and their types and attributes 

ÁDefines how elements relate to one another within the 
document's tree structure and specifies which attributes may 
be used with which elements 
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 Structure of XSD documents 
 

ÁContains the legal building blocks of an XML document similar 
to DTD 

ÁDefines how elements relate to one another within the 
document's tree structure and specifies which attributes may 
be used with which elements 

ÁSchema supports all data types used in most programming 
languages such as string, decimal, integer, Boolean, date and 
time 

ÁSupports complex type elements that allows you to define an 
element type that can consist of sub-elements 
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Using IBM RAD for XML 

 
This product provides a comprehensive visual Extensible Markup 

 Language (XML) development environment. Tools help you  

create, import, edit, validate, and generate XML, XSL, DTDs, and  

XML schemas (XSD) files. Mapping tools help you establish  

relationships between XML files and between XML files and  

relational database tables. 

 

(C) Copyright IBM Corporation 1992, 2005. All Rights Reserved. 
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 Opening an XML document with RAD   
XML document 

 Right click > open with > rationalsdp (eclipse on RAD 7.0) 
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 Create workspace   
Enter C:\Grokking_XML\w!5ψǿƻǊƪǎǇŀŎŜ ŀƴŘ ƭŜŀǾŜ ¦ǎŜ ǘƘƛǎ ŀǎ ǘƘŜ ŘŜŦŀǳƭǘΧΦunchecked! 
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Open a Perspective  
Window>Open Perspective>Other>Resource  
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 Create new project  
In Navigator pane 

 Right Click>New>Project>Simple (General on RAD7.0)>Next   
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 Create new project (continued) 
Enter Project Name Grokking_XML and click Finish 
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 Import employee XML document to project  
Again in Navigator pane 

 Right click Grokking_XML project>Import>(General on RAD7.0) File System>Next>Browse>Select 
XML file>Finish 

 



XML U.S.E.R. 101  

 Create generic schema (XSD) to enable XML Development 
Again in Navigator pane 

 Right click employee.XML document>New>Other>Show All Wizards.>XML>XML Schema>Next> 
Check !ƭǿŀȅǎ ŜƴŀōƭŜ ŎŀǇŀōƛƭƛǘƛŜǎΧ>OK 

 



XML U.S.E.R. 101  

 Create generic schema (XSD)  (continued) 
Enter or select the parent folder Grokking_XML>Leave file name NewXMLSchema.xsd>Finish  
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 Our new generic schema in project  
The Navigator pane is redisplayed showing the new XSD  
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 Delete generic schema (XSD)   
The generic XML Schema generated to enable XML can now be deleted  

 

In the Navigator pane 

 wƛƎƘǘ ŎƭƛŎƪ ǘƘŜ bŜǿ·a[{ŎƘŜƳŀΦȄǎŘ ŘƻŎǳƳŜƴǘҔ5ŜƭŜǘŜҔ/ƭƛŎƪ ¸ŜǎΧ  
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Exit RAD   
Click File>Exit  and if any resources need to be saved prior to exit, Click OK  
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Using IBM RAD for XML recap 

 
What we accomplished: 

Á Created a project to Grok XML 

Á Imported our sample XML document 

 

What we could still accomplish: 

Á Assign a XSD & DTD to our XML document for validation 

Á Edit our XML, XSD & DTD documents in RAD to verify that the XSD & DTD 
generated are accurate in regards to 

ÁRepeating elements are correctly defined 

ÁValidations required for elements/attributes 

ÁRequired elements are defined 

Á Save our document(s) to a mapped IFS folder on our System i 
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Using Excel for XML 

 
New tools in Microsoft Office Excel 2003 and above make it easier to work  

with Extensible Markup Language (XML).  

 

 We will learn how to use these tools to create XML lists and XML maps.  

 

 XML lists have the same look and feel as regular Excel lists, but they take  

their data from XML files.   

 

XML maps are sets of links between the cells in a worksheet and the elements 

 in an XML schema.  You can import data into the map, modify the data, and  

then save the changed data or export it for others to use. 
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 Create an Excel document 
In our Grokking_XML\RAD_workspace\Grokking_XML folder 

 Right click>New>Microsoft Excel Worksheet 
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 Create an Excel document (continued) 

Now name it employee.xls 
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 Create an Excel document (continued) 
Now double click to open it 
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 Importing XML into Excel is easy  
There are two ways we can import our XML data into our spreadsheet: with or without an  

existing Schema (XSD).  

 

In this example, we will simply import the XML data and let Excel generate a schema template  

for us. 

 Click Data>Import External Data> (Developer in 2007) Import Data 
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 Importing XML w/o a schema 
Now select the source of our import, our employee.xml document and click Open  
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 Importing XML w/o a schema (continued) 
Click OK when the Error in XML window is display to instruct Excel to create a schema for us  

and apply to our worksheet  
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 Importing XML w/o a schema (continued) 
Except the defaults on the Import Data window and click OK  
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 Importing XML w/o a schema (continued) 
We have now successfully imported an XML document into an Excel worksheet 
 



XML U.S.E.R. 101  

 Importing XML w/o a schema (continued) 
Notice the bold column names.  This indicates that the schema mappings apply to the columns 

ǎƻ ǘƘŀǘ ŀƴ ·a[ ŘƻŎǳƳŜƴǘ ŎƻǳƭŘ ōŜ ƎŜƴŜǊŀǘŜŘ ŦǊƻƳ ǘƘƛǎ ǿƻǊƪǎƘŜŜǘΦ  [ŜǘΩǎ ŘƛǎǇƭŀȅ ǘƘŜ  

underlying XML of this worksheet.  

 Click Data (Developer in 2007) >XML>XML Source  
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 Importing XML w/o a schema (continued) 
In the XML Source window displayed to the right of our worksheet, the Excel generated  

Employees_Map schema(XSD) is displayed 
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 Importing XML w/o a schema (continued) 
If you click  the Tips for mapping XML link, a help panel is displayed defining more about the  

workings of Excel & XML 
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 Adding an XML Map using a schema (XSD)  
In this example, we will use an existing schema (XSD) as the template. 

 /ƭƛŎƪ 5ŀǘŀ ό5ŜǾŜƭƻǇŜǊ ƛƴ нллтύ Ҕ·a[Ҕ·a[ {ƻǳǊŎŜΧ  
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 Adding an XML Map using a schema (XSD) (continued) 
/ƭƛŎƪ ·a[ aŀǇǎҔ!ŘŘΧҔŜƳǇƭƻȅŜŜΦȄǎŘҔhǇŜƴ 
 



XML U.S.E.R. 101  

 Adding an XML Map using a schema (XSD) (continued) 
Click Employees>OK in the Multiple Roots windows since Employees, not Employee is our root 
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 Adding an XML Map using a schema (XSD) (continued) 
Click OK in the XML Maps windows 
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Adding an XML Map using a schema (XSD) (continued) 
Lƴ ·a[ {ƻǳǊŎŜ ǿƛƴŘƻǿΣ ǊƛƎƘǘ ŎƭƛŎƪ ǘƘŜ 9ƳǇƭƻȅŜŜǎ ǊƻƻǘҔaŀǇ ŜƭŜƳŜƴǘΧҔ/ƭƛŎƪ hY ƛƴ aŀǇ ·a[ 

Element window 
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 Our worksheet with the Employee Map 
Notice the markings on the Employee_Map showing that each element is now mapped to a 

worksheet column and that the columns are now in bold and the XML containment box  
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 Importing the Employee XML document 
Click Data (Developer in 2007) >XML>Import>employee.xml>Import 
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 Our worksheet with the Employee XML data 
Notice the markings on the worksheet that surrounds the column data.  The blue box  

designates the containment of the XML Source template. 
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 Adding data to our worksheet 
Right click a row>Insert>Row>key data to the row to populate each column as you would in any 

worksheet 
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 Saving/Exporting our worksheet 
To save the worksheet as XML data you can either: 

 /ƭƛŎƪ CƛƭŜҔ{ŀǾŜ !ǎΧҔ{ŀǾŜ ŀǎ ǘȅǇŜΥ XML Data(*.xml)>name file>Save 

 /ƭƛŎƪ 5ŀǘŀҔ·a[Ҕ9ȄǇƻǊǘΧҔƴŀƳŜ ŦƛƭŜҔ9ȄǇƻǊǘ 
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 Using Excel for XML recap 

 
What we accomplished: 

Á Imported our employee XML document and generated an XML Map 

Á Applied an existing XSD schema as an XML Map to our worksheet  

Á Imported our employee XML data 

Á Added a row to our worksheet 

Á Saved/Exported our XML data 

 

What we could still accomplish: 

Á Perform editing of column(s) in Excel to validate input 

Á Save our document(s) to a mapped IFS folder on our System i 
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Using SQL for XML composition 

 
Using the System i SQL engine we can create an SQL Procedure that will  

generate the Employee XML document used in our lab so that we can  

understand the simplicity of XML composition without any special coding 

 requirements or tools on our existing System i. 
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 Coding the SQL stored procedure  
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 Coding the SQL stored procedure (continued) 
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 Coding the SQL stored procedure (continued) 
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 Coding the SQL stored procedure (continued) 
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 Coding the SQL stored procedure (continued) 
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 Creating the SQL stored procedure  
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 Executing the SQL stored procedure  
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Some considerations for SQL Composition 

 

Á SQL Stored Procedures contain two parts: a catalog entry and a program 
object. These two items can exist separate of each other but only work 
when both parts are there at run time and are not as easy to implement as 
using a SAVOBJ & RSTOBJ. 

  

Á Work around for this limitation: 

 - Run the SQL Create Procedure statement on each box they are to be 
used on  to create the catalog entry and program object 
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Using SQL for XML decomposition 

 
Using the System i SQL engine we can create an SQL UDTF (User Defined  

Table Function)  that will call an RPGLE program to decompose the Employee  

Department XML document used in our lab so that we can use basic SQL  

processing to drill into our XML document on our System i. 
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 {v[Ωǎ ¦ǎŜǊ 5ŜŦƛƴŜŘ ¢ŀōƭŜ CǳƴŎǘƛƻƴǎ ό¦5¢Cύ 
 

 V5R2 DB2 for i5/OS was enhanced to support user-defined table functions 
(UDTF). 

 

  A UDTF can be used from SQL interfaces to access non-relational data 
sources such as S/36 files and stream files residing in the IFS.  

 

 The UDTF enhancement complemented the user-defined scalar function 
(UDF) capability added way back in V4R4 of OS/400.  

  

  A user-defined function is classified as scalar meaning that the function 
Ŏŀƴ ƻƴƭȅ ǊŜǘǳǊƴ ŀ ǎƛƴƎƭŜ ǾŀƭǳŜ όƻǊ ƻǳǘǇǳǘ ǇŀǊŀƳŜǘŜǊύΦ  ¢ƘŀǘΩǎ ǿƘŜǊŜ ¦5¢Cǎ 
come into play with their ability to return multiple values in the form of a 
table (or result set).   
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 wtDΩǎ ·a[-INTO Built in Function (BIF) 
 

 V5R4 ILE RPG for i5/OS was enhanced to facilitate decomposition of an 
XML document into data structures defined in the program using a non-
validating parser.  

 
 The new operation codes and built-in functions makes the  
 decomposition of the XML data and population of data structure  
 fields automatic and efficient without the developer having to  
 manipulate storage to get the XML data in to workable form. 
 
 The complexity has been removed from the XML decomposition  
 process and the developer now can just concentrate on business  
 logic required to implement the XML data.  
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 Coding the SQL UDTF(continued) 
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 Coding the SQL UDTF (continued) 
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 Coding the RPGLE program  
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 Coding the RPGLE program (continued) 
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 Coding the RPGLE program (continued) 
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 Creating the RPGLE program (continued) 
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 Coding the RPGLE program (continued) 
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 Coding the RPGLE program (continued) 
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 Coding the RPGLE program (continued) 
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 Coding the RPGLE program (continued) 
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 Coding the RPGLE program (continued) 

 


