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What can i doé..i can do XML 
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 Grok 

 

To understand so thoroughly that the observer becomes a part of the observedðto merge, 

 blend, intermarry, lose identity in group experience.  It means almost everything that we  

mean by religion, philosophy, and scienceðand it means as little to us (because we are 

 from Earth) as color means to a blind man. 
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ÅXML has become a standard for cross-platform 
communications 

 

ÅXML has or will impact your business if you 
continue to be in business 

 

ÅXML has gained acceptance as a preferred data 
exchange technology in spite of the limitations 
because of the flexibility and human readable 
formatting 
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What you need to get started: 

 

ÁXML Editing tool(s) 

ÁWDSC, Rational Application Developer (RAD)  (IBM) 

ÁXMLSpy (Altova) 

ÁStylus Studio (Progress Software Corporation) 

ÁMicrosoft Office 2003 or higher 

 

ÁXML Reference(s) 

ÁWDSC Step by Step (MC Press) 

ÁXML for eServer i5 and iSeries (MC Press) 

ÁQshell for iSeries (MC Press) 

ÁXSLT 2nd Edition (WROX) 

ÁW3Schools Online Web Tutorials (www.w3schools.org) 
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What is XML? 

ïXML is short for Extensible Markup Language 

 

Pros of XML? 

ïXML is flexible 

ïXML is self documenting  

ïXML can replace or extend legacy systems 

 

Cons of XML? 

ïXML is verbose 

ïXML can significantly increases the size of your data 

ïXML works best with hierarchal data in a relational 

data base 
 



Grokking XML 

 
There are three main components of XML 

 

ÅXML Document 

ïDocument containing data 

 

ÅXML Document Type Definition (DTD) 

ïDocument that defines the document structure of the 

XML Document 

 

ÅXML Schema Definition (XSD) 

ïDocument that defines the document structure of the 

XML Document in an XML-based alternative to DTD 
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Structure of XML documents 

 

ÅAn XML document has a tree-like structure that is 

hierarchical  

ÅThe document must contain one and only one root 

element 

ÅAn element is the parent of all the elements it contains  

ÅThe elements that are inside a parent element are called 

its children 

ÅSimilarly, the elements that have the same parent 

element are called siblings 
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Structure of DTD documents 

 

ÁContains the list of tags which are allowed within the 

XML document and their types and attributes 

ÁDefines how elements relate to one another within the 

document's tree structure and specifies which attributes 

may be used with which elements 
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Structure of XSD documents 

 

ÅContains the legal building blocks of an XML document 

similar to DTD 

ÅDefines how elements relate to one another within the 

document's tree structure and specifies which attributes 

may be used with which elements 

ÅSchema supports all data types used in most 

programming languages such as string, decimal, integer, 

Boolean, date and time 

ÅSupports complexType elements that allows you to 

define an element type that can consist of sub-elements 
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 Programmatic Approach 
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RAD & XML 

 
This product provides a comprehensive visual Extensible Markup  

Language (XML) development environment. Tools help you create,  

import, edit, validate, and generate XML, XSL, DTDs, and XML  

schemas (XSD) files. Mapping tools help you establish relationships  

between XML files and between XML files and relational database  

tables. 

 

(C) Copyright IBM Corporation 1992, 2005. All Rights Reserved. 
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 Opening an XML document with RAD   
XML document 

 Right click > open with > rationalsdp (eclipse on RAD 7.0) 
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 Create workspace   
Enter C:\Grokking_XML\RAD_workspace and leave Use this as the defaulté.unchecked! 
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Open a Perspective  
Window>Open Perspective>Other>Resource  

 



Grokking XML 

 Create new project  
In Navigator pane 

 Right Click>New>Project>Simple (General on RAD7.0)>Next   
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 Create new project (continued) 
Enter Project Name Grokking_XML and click Finish 
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 Import employee XML document to project  
Again in Navigator pane 

 Right click Grokking_XML project>Import>(General on RAD7.0) File 

System>Next>Browse>Select XML file>Finish 
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 Create generic schema (XSD) to enable XML Development 
Again in Navigator pane 

 Right click employee.XML document>New>Other>Show All Wizards.>XML>XML 

Schema>Next> Check Always enable capabilitiesé>OK 
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 Create generic schema (XSD)  (continued) 
Enter or select the parent folder Grokking_XML>Leave file name NewXMLSchema.xsd>Finish  
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 Our new generic schema in project  
The Navigator pane is redisplayed showing the new XSD  
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 Create employee schema (XSD) 
With XML Development now enabled for our project, we can generate the Employee XSD from  

our existing employee XML document. 

 

In the Navigator pane 

 Right click the employee.xml document>Generate (NOT in RAD7.0) >XML Schemaé  
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 Create employee schema (XSD) (continued)  
Accept the File name as is and click Finish  
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 Create employee schema (XSD) (continued)  
The XML Schema generated window is now displayed, click OK  

 



Grokking XML 

 Delete generic schema (XSD)   
The generic XML Schema generated to enable XML can now be deleted  

 

In the Navigator pane 

 Right click the NewXMLSchema.xsd document>Delete>Click Yesé  
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 Create employee document type definition (DTD) 
With the Employee XSD generated, we can generate the Employee DTD from our existing XSD 

 

In the Navigator pane 

 Right click the employee.xsd document>Generate (NOT in RAD7.0) >DTDé  
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 Create employee document type definition (DTD) (continued)  
Accept the File name as is and click Finish  
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 Create employee document type definition (DTD) (continued)  
The DTD generated window is now displayed, click OK  
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Exit RAD   
Click File>Exit  and if any resources need to be saved prior to exit, Click OK  
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RAD & XML recap 

 
What we accomplished: 

Á Created a project to Grok XML 

Á Imported our sample XML document 

Á Generated an XSD & DTD from the XML document 

 

What we could still accomplish: 

Á Assign our XSD & DTD to our XML document for validation 

Á Edit our XML, XSD & DTD documents in RAD to verify that the XSD & DTD 

generated are accurate in regards to 

Á Repeating elements are correctly defined 

Á Validations required for elements/attributes 

Á Required elements are defined 

Á Save our document(s) to a mapped IFS folder on our System i 
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Excel & XML 

 
New tools in Microsoft Office Excel 2003 make it easier to work with  

Extensible Markup Language (XML).  Learn how to use these tools to  

create XML lists and XML maps.  XML lists have the same look and feel 

as regular Excel lists, but they take their data from XML files.  XML maps 

are sets of links between the cells in a worksheet and the elements in  

an XML schema.  You can import data into the map, modify the data,  

and then save the changed data or export it for others to use. 
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 Create an Excel document 
In our Grokking_XML\RAD_workspace\Grokking_XML folder 

 Right click>New>Microsoft Excel Worksheet 
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 Create an Excel document (continued) 

Now name it employee.xls 
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 Create an Excel document (continued) 
Now double click to open it 
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 Importing XML into Excel is easy  
There are two ways we can import our XML data into our spreadsheet: with or without an  

existing Schema (XSD).  

 

In this example, we will simply import the XML data and let Excel generate a schema template  

for us. 

 Click Data>Import External Data>Import Data  
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 Importing XML w/o a schema 
Now select the source of our import, our employee.xml document and click Open  
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 Importing XML w/o a schema (continued) 
Click OK when the Error in XML window is display to instruct Excel to create a schema for us  

and apply to our worksheet  
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 Importing XML w/o a schema (continued) 
Except the defaults on the Import Data window and click OK  
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 Importing XML w/o a schema (continued) 
We have now successfully imported an XML document into an Excel worksheet 
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 Importing XML w/o a schema (continued) 
Notice the bold column names.  This indicates that the schema mappings apply to the columns 

so that an XML document could be generated from this worksheet.  Letôs display the  

underlying XML of this worksheet.  

 Click Data>XML>XML Source  
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 Importing XML w/o a schema (continued) 
In the XML Source window displayed to the right of our worksheet, the Excel generated  

Employees_Map schema(XSD) is displayed 
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 Importing XML w/o a schema (continued) 
If you click  the Tips for mapping XML link, a help panel is displayed defining more about the  

workings of Excel & XML 
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 Adding an XML Map using a schema (XSD)  
In this example, we will use an existing schema (XSD) as the template. 

 Click Data>XML>XML Sourceé  
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 Adding an XML Map using a schema (XSD) (continued) 
Click XML Maps>Addé>employee.xsd>Open 
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 Adding an XML Map using a schema (XSD) (continued) 
Click Employees>OK in the Multiple Roots windows since Employees, not Employee is our root 
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 Adding an XML Map using a schema (XSD) (continued) 
Click OK in the XML Maps windows 
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Adding an XML Map using a schema (XSD) (continued) 
In XML Source window, right click the Employees root>Map elementé>Click OK in Map XML 

Element window 
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 Our worksheet with the Employee Map 
Notice the markings on the Employee_Map showing that each element is now mapped to a 

worksheet column and that the columns are now in bold and the XML containment box  
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 Importing the Employee XML document 
Click Data>XML>Import>employee.xml>Import 
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 Our worksheet with the Employee XML data 
Notice the markings on the worksheet that surrounds the column data.  The blue box  

designates the containment of the XML Source template. 
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 Adding data to our worksheet 
Right click a row>Insert>Row>key data to the row to populate each column as you would in any 

worksheet 
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 Saving/Exporting our worksheet 
To save the worksheet as XML data you can either: 

 Click File>Save Asé>Save as type: XML Data(*.xml)>name file>Save 

 Click Data>XML>Exporté>name file>Export 
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 Excel & XML recap 

 
What we accomplished: 

Á Imported our employee XML document and generated an XML Map 

Á Applied an existing XSD schema as an XML Map to our worksheet  

Á Imported our employee XML data 

Á Added a row to our worksheet 

Á Saved/Exported our XML data 

 

What we could still accomplish: 

Á Perform editing of column(s) in Excel to validate input 

Á Save our document(s) to a mapped IFS folder on our System i 
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SQL & XML composition 

 
Using the System i SQL engine we can create an SQL Procedure that  

will generate the Employee XML document used in our lab so that we can  

understand the simplicity of XML composition without any special coding  

requirements or tools on our existing System i. 
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Coding the SQL stored procedure  
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 Coding the SQL stored procedure (continued) 
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 Coding the SQL stored procedure (continued) 
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 Coding the SQL stored procedure (continued) 
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 Coding the SQL stored procedure (continued) 
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 Creating the SQL stored procedure  

 


